[TMA1] We are currently experiencing increased processing delays which may impact the trigger service
Incident Report for The Mill Adventure Limited
Resolved
The incident has been resolved and the service is operational again
Posted Nov 23, 2024 - 15:19 UTC
Investigating
We are currently investigating this issue.
Posted Nov 23, 2024 - 14:55 UTC
This incident affected: The Mill Adventure (TMA1) (TMA1 - Gaming Platform (Auxiliary Services)).