[TMASW1] We are currently experiencing increased processing delays which may impact the kyc service
Incident Report for The Mill Adventure Limited
Resolved
The incident has been resolved and the service is operational again
Posted Nov 22, 2024 - 12:23 UTC
Investigating
We are currently investigating this issue.
Posted Nov 22, 2024 - 11:51 UTC
This incident affected: The Mill Software (TMASW1) (TMASW1 - Gaming Platform (Auxiliary Services)).