Trustly Service Update-> Sweden and Finland - Nordea - 2024-11-25
Incident Report for The Mill Adventure Limited
Resolved
Hello,

Please be informed that the issue reported earlier with Nordea in Sweden and Finland has been resolved.

The service has been restored to its full functionality.

--
Want to keep an eye on Trustly services? Go to https://status.trustly.net to check the connection status of Trustly services and banks' open API.

Please note that this mailbox is not regularly monitored.
Contact support@trustly.com with any questions, comments or concerns.

Kind regards,
Trustly Team
Posted Nov 25, 2024 - 09:52 UTC
Monitoring
Hello,

Please be advised that we are currently experiencing a service degradation for Nordea in Sweden and Finland affecting deposits.

This is due to a technical issue on the bank’s end.

We are monitoring the situation and will advise you when the service is restored.

--
Want to keep an eye on Trustly services? Go to https://status.trustly.net to check the connection status of Trustly services and banks' open API.

Please note that this mailbox is not regularly monitored.
Contact support@trustly.com with any questions, comments or concerns.

Kind regards,
Trustly Team
Posted Nov 25, 2024 - 09:25 UTC
This incident affected: Payment Service Providers (Trustly).