Trustly: We would like to inform you that due to an increase in unsettled rates for ICA Banken in Sweden, the bank has now been classified as “Basic”.
Incident Report for The Mill Adventure Limited
Update
We are continuing to investigate this issue.
Posted Jan 13, 2023 - 11:39 UTC
Investigating
Since you chose to only use “Standard” banks, ICA Banken has been disabled.

We are working on a solution to return this bank back to “Standard” as soon as possible. Further information will be shared as soon as it becomes available.
Posted Feb 09, 2022 - 17:10 UTC
This incident affects: Payment Service Providers (Trustly).